View Issue Details

IDProjectCategoryView StatusLast Update
0000089TeraCopy(No Category)public2017-09-14 12:02
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status newResolutionopen 
Product Version3.0 
Target VersionFixed in Version 
Summary0000089: Folder not deleted after MOVE
DescriptionI can't reproduce the problem but I noticed that, sometimes, when I move some files and folders, all is ok but an empty folder remains in the source.
TagsNo tags attached.
OSWindows 10
OS Version64 bit




2017-03-15 05:51

reporter   ~0000058

Maybe it's not TC but another program locking the folder? E.g. folder open in file explorer, an opened text document from the folder etc.? That's usually the reason when I have remaining folders.


2017-03-15 08:23

reporter   ~0000059

I do not know, I can not replicate, occurs very rarely. Is it possible what you write, but I'm able to eliminate the empty folder manually, moreover, before it occurred the folder was not empty, all the files was moved. I expected to find a locked file, in the folder, or if it is a locked folder (active environment), why can I delete it manually? I could disable the AV (I have no other active applications), but it is not a good idea for security. For now, I have no more information, but, perhaps, you can add, in the app, a function for this problem (a detailed dialog to the user, which may decide whether to retry or stop). So I can help seriously, case by case, I can see what is the reason that locks.


2017-03-16 03:17

reporter   ~0000060

I have made a test and, according to me, the problem only occurs using the function: COPY on the same unit (I use an SSD but, probably, is not a useful info). The result of this function is like the MOVE. I used drag & drop. I "copied" some files and folders, at the end I noticed an empty folder in the source (not empty because it contained an empty subfolder), not other. The destination was ok. So, I tried to re-copy the empty folder, various times, with the same result. When I used the teramove function from the context menu, all was done. I hope this can help.


2017-03-17 03:17

reporter   ~0000061

The problem occurs also with MOVE, not only with COPY on the same unit (both drag & drop). I saw this problem after compressing by WinRAR what I want to move, so I can try to reproduce, maybe a RAR process can lock.


2017-03-24 06:51

reporter   ~0000076

The folder that is not deleted is always the same: App
Is a folder that is always available in the PortableApps Format, the problem occurs frequently, also if the application in this folder is not ever started (not a lock problem). For now, I noticed that the problem occurs after that I have compressed the folder by WinRAR and I move it, but I can immediately delete the undeleted folder manually.


2017-08-09 12:07

reporter   ~0000154

What's probably causing this is that the hidden system file desktop.ini is being copied but without admin privileges TC cannot delete it from the original location hence the folder does not get deleted either.

You can double check this by showing all hidden and system files, and check the original folder for desktop.ini file.


2017-09-14 09:37

reporter   ~0000165

I see this behaviour quite often with Teracopy v3.2, when moving a folder tree. The root folder is frequently left behind, empty, at the source location.
It ISN'T because of desktop.ini or any other hidden/system files in the folder: I have my system set up to show those, and it really is an empty folder.

Incidentally, this can happen even when doing same-drive moves. This is fishy, because when doing a same-drive move, all TeraCopy should be doing is relocating file/folder directory records, not touching the data in the files at all. Perhaps TeraCopy is making a copy of the root folder if it's locked and can't be moved (and then moving the files within it to the new copy). But if that's the case, TeraCopy should be giving an error saying the root folder is locked, not going ahead and then leaving empty folders behind!

Issue History

Date Modified Username Field Change
2017-03-13 03:26 GlacialMan New Issue
2017-03-15 05:51 BRX Note Added: 0000058
2017-03-15 08:23 GlacialMan Note Added: 0000059
2017-03-16 03:17 GlacialMan Note Added: 0000060
2017-03-17 03:17 GlacialMan Note Added: 0000061
2017-03-24 06:51 GlacialMan Note Added: 0000076
2017-08-09 12:07 tcbluemoon33333 Note Added: 0000154
2017-09-14 09:37 Dean0 Note Added: 0000165